AegisWeb requires Windows 2000 or Windows XP and Internet Explorer 5.5 or better to run.

Please run Internet Explorer from a supported Operating System and browse to https://gulf3.gie.com/aegisweb/GLF.asp.